Aller au contenu principal
Sujet: traitement de texte et problèmes imprimer (Lu 104 fois) sujet précédent - sujet suivant
0 Membres et 1 Invitédans ce sujet

traitement de texte et problèmes imprimer

Bonjour


J'essaie de mettre au point Xenial 32

J'ai bien du mal à trouver un traitement de texte qui me convienne. Ce que je souhaite : un traitement de textes en français (je ne suis pas le seul utilisateur), Par défaut, mon imprimante (et non CUPS), format par défaut .odt, format A4 par défaut, imprimer recto/verso.

Libre office (5.1.6) par le PPM de xenial  : en anglais, le pack fr dans le PPM ne fonctionne pas. J'ai tenté un autre pack fr, mais idem

Abiword : j'ai pu régler le format .odt par défaut. Mais le réglage des marges est un problème. Je n'ai pu régler le problème d'une page blanche qui précède le texte enregistré qu'en me servant systématiquement d'un modèle que j'ai placé sur mon bureau. Pas moyen que mon imprimante soit l'imprimante par défaut au lieu de CUPS. Je n'ai pas réussi à trouver comment imprimer en recto/verso

J'ai installé OpenOffice aOO-4.1.4.5_FR-i386.sfs que j'ai trouvé là : https://augras.eu/puppy_linux/?m&dir=musher0/apacheOpenOffice
Pas d’entrée menu mais je le trouve dans /usr/share/applications. Je fais glisser les icônes sur le bureau. C'est en français. Là, pas de problème pour que mon imprimante soit l'imprimante par défaut. Pas de problème pour que le format par défaut soit .odt. Réglage des marges sans difficulté.

J'ai vu qu'il faut Java pour que OpenOffice fonctionne correctement. Donc, dans le PPM, je l'ai téléchargé. Avec Pfind, j'ai trouvé où se trouvait java, mais il y a plusieurs localisations.  Puis, dans le Writer d’OpenOffice, je suis allé sur outils – options -java – ajouter. Là, il faut que j'écrive le chemin de java.  J'ai essayé différentes possibilités de chemin, mais j'ai, la plupart du temps, un message qui me dit « ...il n'y a pas d'environnement d'exécution Java dans le dossier sélectionné.... ». Peut être que mes problèmes viennent de là ?

Problème bien gênant : le format par défaut est « letter », alors qu'il me faut le format A4.
J'ai essayé plusieurs choses.


Dans le menu de Xenial, si je vais sur configuration – assistant d'impression, une page abiword s'ouvre, avec plein  de ce qui ressemble à des liens mais qui ne fonctionnent pas...

Dans OpenOffice writer, fichier – paramétrage de l'imprimante – propriétés, je remplace « letter » par A4 puis OK. Mais si j'y retourne, je ne peut que constater que c'est revenu automatiquement sur « letter »....

J'ouvre printeradmin d'OpenOffice – propriétés, et je remplace « letter » par A4. Idem que ci-dessus : retour automatique sur « letter »

Finalement, la seule chose qui fonctionne est, sur un document créé, lorsque je clique sur « imprimer », d'aller systématiquement sur « propriétés », de changer « letter » par A4, avant de confirmer l'impression. Mais il faut le refaire à chaque fois. Ce serait plus simple de réussir à changer le réglage par défaut.

Enfin, je n'ai pas réussi a trouver comment imprimer recto verso, ce qui est bien utile pour éviter les envois postaux trop lourds.  En cherchant sur Internet, j'ai vu que je devrais n'avoir qu' à cocher cette option. Mais cette option ne figure pas dans mon OpenOffice. Peut être lui manque t il quelque chose ? En attendant, je n'ai pas d'autre option que de retourner sur  windows...

Re : traitement de texte et problèmes imprimer

Répondre #1
Bonjour Gilles,
Pas d'inquiétude : tout ce que tu décris à une solution... ça fonctionne chez moi et sans grandes difficultés.
Par contre je suis en vacances et je ne pourrai répondre correctement qu'à mon retour aux alentours du 15 août. Désolé.
Philippe

Re : traitement de texte et problèmes imprimer

Répondre #2
Bonjour, 

C'est sympa de me répondre. Il n'y a pas d'urgence. J'attendrai

Je te souhaite de très bonnes vacances

Cordialement

Re : traitement de texte et problèmes imprimer

Répondre #3
Bonjour,

Après avoir bien galéré, j''ai pu trouver la solution à presque tous les problèmes cités dans mon 1er message.
Donc, pour aider ceux qui auraient les mêmes problèmes, j'indique les solutions trouvées

Abiword :
- Ouvrir Abiword et créer son modèle (marges, casse, etc).
- Ne rien taper dans le texte, sauf si on veut que ça apparaisse d'office à toute ouverture d'Abiword.
- Nom du fichier à écrire : normal
- "enregistrer sous"
- Sélectionner, en bas, le type abiword template (.awt)
- enregistrer dans "my_documents"
- En haut, à gauche de l'écran, cliquer sur l'icône "fichiers" (Rox),
- cliquer sur "my_documents"
- Toujours sur Rox, ouvrir une deuxième fenêtre, cliquer sur root
- cliquer sur l'oeil qui se trouve dans la barre des tâches
- cliquer sur .config
- cliquer sur abiword
- cliquer sur templates
- Revenir à la première fenêtre ouverte avec Rox et faire glisser le fichier que vous avez nommé normal (normal.awt) vers la fenêtre templates.
-choisir l'option déplacer

C'est fait. Désormais, lorsque vous ouvrirez Abiword, c'est votre page modèle (marges, casse, etc ) qui s'ouvrira.
Par ailleurs, mon problème de page blanche qui précédait tout texte enregistré, a disparu grâce à cette manipulation. 

Problème de format letter au lieu de A4 et imprimante par défaut :
Le problème venait de ce que, par manque d'expérience, lors de l'installation de mon imprimante avec CUPS, je n'avais pas sélectionné le format A4 au lieu de letter, et que je n'avais pas réglé, dans CUPS, mon imprimante comme imprimante par défaut.
Pour régler le problème, retourner dans CUPS en tapant dans un navigateur (firefox, palemoon, chromium ou autre) localhost:631
Ou bien, puisque c'est en anglais, pour ceux qui ne sont pas anglophones, pour que votre imprimante par par défaut soit la vôtre au lieu de CUPS, ce n'est peut être pas plus difficile de faire comme suit : Dans Rox, aller à etc, cups, printer config, et changer les lignes 4 et 23 : defaultprinter avant le nom de votre imprimante au lieu de avant CUPS
Donc, le problème est réglé, à la fois pour Abiword et pour le writer d'open office.

Recto verso avec Abiword :
Cliquer sur imprimer, aller sur "mise en page", et en face de recto verso, choisir "bord long (standart)". Ce n'était pas évident de deviner que "bord long standart" correspond à recto-verso !!!

Avec OpenOffice le problème recto verso reste entier ! C'est dommage car le writer d'open office est plus performant qu'Abiword.

Bien cordialement







 
Simple Audio Video Embedder