Aller au contenu principal
Sujet: Firefox ESR et classique (Lu 787 fois) sujet précédent - sujet suivant
0 Membres et 1 Invitédans ce sujet

Firefox ESR et classique

Bonjour,
J'initie ici le fil dédié à Firefox.
La version 60 vient de sortir mais surtout avec elle la version 60ESR : le précédente version ESR étant la 52.9.
C'est quoi une version ESR ? Et bien ESR pour Extended Support Release, littéralement Version à Support Étendu.
Concrètement c'est une version à l'origine prévue pour les entreprises qui ne peuvent pas se permettre de suivre le rythme des mise à jours des versions classiques. Entre la version 52 et 60 se sont donc 8 versions de Firefox qui se sont succédées : c'est parfaitement impossible pour une entreprise de revalider à chaque version l'ensemble de ses applications.
Entre 2 versions ESR il y a entre 12 et 15 mois et la première continue à être maintenue un certains nombres de mois en parallèle de la suivante : dans les faits l'entreprise peut se limiter à une mise à jour tous les 2 ans.
Un tableau récapitulatif des sorties des versions de firefox :

La différence entre une version classique et ESR ne tient pas qu'à cela : une version ESR ne bénéficie pas des évolutions des versions classiques. En effet les fonctionnalités d'une version ESR resteront les mêmes que celles de la version classique correspondante : seules les mises mise à jour de sécurité sont effectuées. C'est le moyen trouvé par Mozilla pour maintenir une version ESR.

Alors pourquoi une version ESR pour nos Toutous plutôt qu'un version classique ?
Toute mise à jour n'est pas positive et donc bonne à faire ! Les soucis récurrents de son avec Firefox sous Linux en sont la preuve.
Une version ESR a sans soucis particulier une durée de vie de 2 ans avec des mises à jour de sécurité au moins pendant 18 mois : c'est toujours bon à prendre même si sous Linux on a beaucoup moins de risque d'être embêté sur ce point.
La stabilité sous Puppy Linux on aime ça !

Je viens de faire la mise à jour vers la version 60ESR de Firefox et pas de soucis, même avec le son : lors de la dernière mise à jour vers la version 52 gros soucis puisque Mozilla avait décidé d'utiliser désormais pulsaudio à la place d'Alsa. Et à des fins de test j'avais installé la version classique qui au fil des mises à jour successives perdait parfois à nouveau le son !
Là rien de tel et tout va bien... pour une fois !
Vous pouvez télécharger les versions ESR de Firefox sur le lien suivant : https://www.mozilla.org/en-US/firefox/organizations/all/
Vous aurez le choix des versions, 52 ou 60, 32 ou 64 bits, et un grand nombre de langues dont le français.
Vous téléchargez un fichier compressé : il suffit de le décompresser (clic droit puis UExctract par exemple). Et vous le mettez où vous voulez. Personnellement Firefox est sous /opt/firefox.
Si vous faites la même chose vous allez pouvoir utiliser le fichier firefox.desktop joint (sinon il faudra le modifier pour indiquer le bon chemin de l'exécutable). Ce fichier est à copier dans /usr/applications : rafraichir vos menus et normalement Firefox y sera.
Il y aura peut-être un soucis avec l'icône qui chez moi se trouve dans /usr/share/icons/Puppy Standard/scalable/apps/ et s'appelle firefox.svg : je mets donc également en pièce jointe le fichier de l'icône, si soucis il faut mettre ce fichier dans /usr/share/icons/Puppy Standard/scalable/apps/. Mais je n'ai rien fait de spécial et à priori ce fichier devrait être présent sur votre Toutou.
Et les plus curieux se rendrons compte en regardant le contenu du fichier .desktop que la ligne Exec= débute par apulse. C'est obligatoire pour avoir le son sous Firefox.
Si apulse est installé pas de soucis, sinon il est dans le PPM et il faut l'installer.
Je viens de faire mon test classique de vérification de lecture des vidéos : replay des chaines de France TV, replay M6, Youtube et pour terminer Netlix : tout est ok sans rien avoir fait de spécial.
J'ai fait ce test sous xenial7.5. Il se peut que sur d'autres versions, plus anciennes, vous ayez avec Netflix le problème de libavcodec : si cela arrive vous le voyez une fois connecté à Netflix avec un petit bandeau qui apparaît en haut de la fenêtre sous la barre d'adresse. Dans ce cas il faut dans la barre d'adresse saisir about:config puis valider, y compris après l'avertissement, et faire une recherche sur libavcodec. Il y a une ligne "media.libavcodec.allow-obsolete" dont la valeur doit être sur "false" : double cliquer sur "false" et changer en "true".
Philippe

EDIT1
Mise à jour en version 60.0.2ESR ce matin (10/06/2018) et pas de soucis particulier : Netflix et compagnie sont opérationnels.
Philippe

EDIT2
Mise à jour en version 60.0.3ESR automatiquement depuis firefox et pas de soucis.
Philippe

 
Simple Audio Video Embedder